androidX is killing me!

How do we specify a build version that still uses android.support.v4? Too many plugins are just not there and it’s killing me!

The problem is that if you use an older version of Android, I don’t think it will be accepted in the Play Store.

I used that to auto-convert my plugins to AndroidX.

<preference name="android-minSdkVersion" value="22" />
<preference name="android-targetSdkVersion" value="29" />
...
<preference name="AndroidXEnabled" value="true" />
<preference name="JetifierEnabled" value="true" />
<plugin name="cordova-plugin-androidx-adapter" spec="1.1.1" />
<plugin name="cordova-android-play-services-gradle-release" spec="4.0.0" />
1 Like

I just started down that path… found the androidx-adapter 2 days ago but hadn’t yet figured out all your settings so thanks for sharing!

After a long break away I’m back at this…

@VoltBuilderSupport - Are you allowing jetifier to run? I’m still getting two androidx related build errors and one is from the cordova-plugin-googlemaps which is an absolute requirement.

cordova-plugin-googlemaps is on the green list, so VoltBuilder is happy to build with it. We also aren’t restricting Jetifier.

That doesn’t mean it’s all going to work. You might ask on the Cordova Slack channel if there are tips.

https://cordova.slack.com/archives/C068CHRJ5

Sorry about that - I didn’t mean to point you at a specific message. Just the Cordova Slack in general.